Excel HVIS funktion

HVIS funktionen

Resumé

Funktionen HVIS kan udføre en logisk test og returnere en værdi for et SAND resultat, og et andet for et FALSK resultat. For eksempel for at bestå en eksamen skal man score mindst 70 point: =HVIS(A1> 70;”Bestået”;”Dumpet”). Mere end en betingelse kan testes ved at indlejre HVIS funktioner. HVIS funktionen kan kombineres med logiske funktioner som OG og ELLER.

Formål

Test for en bestemt betingelse

Returværdi

De værdier du leverer for SAND eller FALSK

Syntaks

=HVIS(logisk_test, [værdi_hvis_sand], [værdi_hvis_falsk])

Argumenter

logisk_test – En værdi eller et logisk udtryk, som kan vurderes som SAND eller FALSK.

værdi_hvis_sand – [valgfrit] Værdien, der skal returneres, når logisk_test evalueres til SAND.

værdi_hvis_falsk – [valgfrit] Værdien, der skal returneres, når logisk_test evalueres til FALSK.

Brugsanvisninger

Brug funktionen HVIS til at teste for eller evaluere visse forhold, og derefter agere afhængigt af om testen var SAND eller FALSK.

For eksempel, lad os sige, at du vil tildele resultatet Bestået eller Dumpet til elever baseret på en score. I så fald skal du teste scoren for hver elev, og returnere enten Bestået eller Dumpet.

Hvis du har en score i celle C6, og du ønskede at undersøge denne score for at se om den er mindst 70, ville du bruge denne formel:

=C6>=70

Dette oversætter til “C6 indeholder en værdi større end eller lig med 70”. Det vil enten være SAND eller FALSK, afhængigt af værdien i C6. Du tilføjer derefter en værdi, som HVIS funktionen skal returnere, hvis testen er SAND, og en værdi, der skal bruges, hvis testen er FALSK.

Hvis vi sætter det hele sammen, skal du bruge denne formel:

=HVIS(C6>=70;”Bestået”;”Dumpet”)

Det er den formel, der vises D6 i det viste eksempel. Når den kopieres ned over kolonnen, vil den undersøge hver score, og returnere det korrekte resultat.

Indlejret HVIS sætninger

Dette refererer til at brugen mere end en HVIS-funktion, så du kan teste for flere forhold og returnere flere forskellige resultater. Hver HVIS erklæring skal omhyggeligt “indlejres” i en anden, så logikken er korrekt.

For eksempel kan følgende formel bruges til at tildele en karakter frem for et Bestået/Dumpet-resultat:

=HVIS(C6<70,"F",IF(C6<75,"D",IF(C6<85,"C",IF(C6<95,"B","A"))))

Op til 64 HVIS funktioner kan indlejres. Men generelt bør du overveje andre funktioner, som LOPSLAG eller VOPSLAG til mere komplekse scenarier. De kan håndtere flere betingelser på en langt mere strømlinet måde.

Logiske operatorer

Når du konstruerer en test med HVIS, kan du bruge en af følgende logiske operatorer:

Operator Betydning Eksempel
= Lig med A1=D1
> Større end A1>D1
>= Større end eller lig med A1>=D1
<= Mindre end eller lig med A1<=D1
<> Forskellig fra A1<>D1

Skriv et svar

Din e-mailadresse vil ikke blive publiceret. Krævede felter er markeret med *

five × 5 =