Excel MIDDEL og MIDDELV funktioner

Excels regnearksfunktion MIDDEL beregner gennemsnittet af et sæt af tal. Figuren neden for viser data og dialogboksen Funktionsargumenter for MIDDEL.

Her er trinene:

  1. I dit regneark indtaster du dine tal i en array af celler og vælg de celler du vil have MIDDEL skal finde resultatet af.

I dette eksempel har jeg indtastet 48, 75, 62, 36, 25 og 89 i cellerne B2 til B7, og jeg har valgt celle B8 til resultatet.

  1. I menuen over Statistiske funktioner vælges MIDDEL. Du ser nu dialogboksen Funktionsargumenter for MIDDEL.
  2. I dialogboksen Funktionsargumenter indtastet værdien for argumenterne.

Hvis arrayet med talcellerne ikke allerede bliver vist i feltet Tal1 indtastes dem i feltet. Gennemsnittet (i dette tilfælde 55,83) vises i dialogboksen.

  1. Klik OK for at lukke dialogboksen Funktionsargumenter for MIDDEL.

Gennemsnittet indsættes i cellen, der er valgt i regnearket. I dette eksempel celle B8.

Som du kan se i figuren er formlen i formellinjen

=MIDDEL(B2:B7)

Hvis jeg havde navngivet området B2 til B7 med f.eks. navnet Tal havde formlen set sådan ud

=MIDDEL(Tal)

MIDDELV gør det samme som MIDDEL, men med en vigtig forskel: Når MIDDEL beregner et gennemsnit, ignorere den celler, der indeholder tekst, og den ignorerer celler, der indeholder udtrykkene SAND og FALSK. MIDDELV tager tekst og udtryk under overvejelse når den beregner et gennemsnit. Hvad angår MIDDELV, hvis en celle indeholder tekst eller ordet FALSK, får det værdien 0. Hvis en celle indeholder ordet SAND får det værdien 1. MIDDELV tager disse værdier med i gennemsnittet.

Jeg er ikke sikker på du vil få brug for denne mulighed i almindelige statistiske opgaver (Jeg har aldring), men Excel har regnearksfunktioner som MIDDELV, VARIANSV og STDAFVV, og jeg synes det kan være en god ide du ved, hvordan de fungerer. Her er trinene for MIDDELV:

  1. Indtast tallene i dit regneark og vælg cellen der skal indeholde resultatet.

I dette eksempel har jeg indtastet 48, 75, 62, 36, 25 og 89 i cellerne B2 til B7, og valgt B9. Dette lader B8 være tom. Jeg har gjort dette fordi jeg vil indtaste forskellige værdier i B8 og vise dig effekten på MIDDELV.

  1. I menuen over Statistiske funktioner vælges MIDDELV. Du ser nu dialogboksen Funktionsargumenter for MIDDELV.
  2. I dialogboksen Funktionsargumenter indtastes værdien for argumenterne.

Denne gang indtaster jeg B2:B8 i feltet Tal1. Gennemsnittet (i dette tilfælde 55,83) vises i dialogboksen. MIDDELV ignorerer tomme celler på samme måde som MIDDEL.

  1. Klik OK for at lukke dialogboksen Funktionsargumenter, svaret indsættes i den valgte celle.

Nu kan vi eksperimentere lidt. Hvis jeg indtaster xxx i celle B8 vil gennemsnittet i celle B9 ændres fra 55,83 til 47,85. Hvis du nu indtaste SAND i celle B8 vil gennemsnittet i celle B9 ændres til 48. Til sidste indtaster jeg FALSK i celle B8 og gennemsnittet ændres til 47,85.

Hvorfor disse ændringer? MIDDELV beregner en tekststreng som xxx, som et nul. Derfor er gennemsnittet i dette tilfælde baseret på syv tal (ikke seks), hvor et er nul. MIDDELV beregner SAND som 1. Så gennemsnittet med SAND i celle B8 er baseret på syv tal, hvor et af dem er 1,00. MIDDELV beregner FALSK som nul, og beregner det samme gennemsnit som hvis celle B8 havde xxx.

Skriv et svar

Din e-mailadresse vil ikke blive publiceret. Krævede felter er markeret med *

17 − sixteen =