Generering af tilfældige tal

Excel værktøjet Generering af tilfældige tal er skræddersyet til at lave simuleringer. Fortæl hvor mange værdier du vil generere, giv den en sandsynlighedsfordeling at arbejde med, og den vil tilfældigt generere tal i overensstemmelse med parametrene i fordelingen. I dette eksempel vil hvert genereret tal korrespondere til et kast med en terning.

Her kan du se hvordan du bruger værktøjet Generering af tilfældige tal:

1. Vælg Data -> Dataanalyse for at åbne dialogboksen Dataanalyse.

2. I dialogboksen Dataanalyse rulles ned på listen Analyseværktøj og vælges Generering af tilfældige tal.

3. Klik OK for at åbne dialogboksen Generering af tilfældige tal.

Figuren viser dialogboksen Generering af tilfældige tal.

4. I feltet Antal variabler indtastes antallet af variabler du vil oprette tilfældige tal til.

Jeg ved det godt man bør ikke ende en sætning med en præposition. Men seriøst så har jeg indtastet 1 i dette eksempel. Jeg er kun interesseret i udfaldet af kast med et par terninger.

5. I feltet Antal tilfældige tal indtastes antallet der skal genereres.

Jeg har indtastet 200 for at simulere 200 kast med terningen.

6. I feltet Fordeling klikkes på listepilen for at vælge fordelingstypen.

Du har her syv muligheder. Valget du foretager dig afgør, hvad der vises i området Parametre i dialogboksen, fordi forskellige typer af fordelinger har forskellige typer (og antal) parametre. Her arbejder du med en diskret stokastisk variabel, så det passende valg er Diskret.

7. Ved at vælge Diskret dukker feltet Inputområde og sandsynlighed op i området Parametre. Indtast et array der skal indeholde celler med værdier af variabler og deres tilhørende sandsynligheder.

De mulige udfald af terningkastene er i A2:A12, og sandsynlighederne er i B2:B12, så området er A2:B12. Excel tilføjer dollartegn ($) for absolutte referencer.

8. I Outputindstillinger vælges en radioknap for at indikere, hvor du vil have resultatet.

Jeg har valgt Ny regnearksfane for at placere resultatet på en ny fane i projektmappen.

9. Klik OK.

Fordi jeg valgte Ny regnearksfane vil den nyligt oprettet fane åbnes med resultatet. Figuren viser den nye fane. De tilfældigt genererede tal er i kolonne A. De 200 rækker med tilfældige tal er for lang til at blive vist her. Jeg kunne have klippet og indsat dem i ti kolonner af 20 celler, men du ville bare se på 200 tilfældige tal.

I stedet har jeg brugt FREKVENS til at gruppere tallene i frekvenser i kolonne C og D, og derefter brugt Excels grafiske evner til at oprette en graf med resultaterne. Jeg har valgt D2, så formellinjen viser hvordan jeg har brugt FREKVENS i denne celle. Som du kan se har jeg defineret TERNINGKAST som navnet til A2:A201 og x som navn for C2:C12.

Generering af tilfældige tal

Hvad med statistikken for disse simulerede terningkast?

=MIDDEL(TERNINGKAST)

Fortæller dig at gennemsnittet er 7,01.

=VARIANS.S(TERNINGKAST)

Returnerer 5,336583 som den anslåede varians, og KVROD af variansen returnerer 2,310105 som den anslåede standardafvigelse.

Bo Jönsson

Skriv et svar

Din e-mailadresse vil ikke blive publiceret. Krævede felter er markeret med *

12 − eleven =