Sammenlign to områder ved hjælp af betinget formatering

En almindelig opgave er at sammenligne to lister med elementer for at finde frem til forskellen mellem de to lister. Hvis det skal gøres manuelt bliver det alt for kedeligt og fyldt med fejl. Excel kan gøre det nemt. Dette tip beskriver en metode, der bruger betinget formatering.

Figuren viser et eksempel med to kolonner med navne. Ved at tilføje betinget formatering kan forskellen mellem to lister vises med det samme. Dette eksempel indeholder lister med tekst, men denne teknik kan også bruges til numerisk data.

Den første liste er i A2:A13 og området er navngivet Gammel_liste. Den anden liste er i C2:C13 og området er navngivet Ny_liste. Områderne er navngivet ved at bruge funktionen Formler -> Definer navne -> Definer navne. Det er ikke nødvendigt at navngive områderne, men det gør det nemmere at arbejde med dem.

Start med at tilføje betinget formatering til den gamle liste:

Marker cellerne i området Gammel_liste.

Vælg Hjem -> Betinget formatering -> Ny regel for at se dialogboksen Ny formateringsregel.

I dialogboksen Ny formateringsregel klikkes på regeltypen der hedder Brug en formel til at bestemme, hvilke celler der skal formateres.

Indtast følgende formel i dialogboksen (se figuren):

=TÆL.HVIS(Ny_liste;A2)=0

Når du bruger denne teknik med dine egne data, erstatter du det aktuelle område (eller navn) med dit eget område.

Klik på knappen Formater og specificer formateringen der skal tilføjes når betingelsen er sand.

Klik OK.

Cellerne i området Ny_liste benytter en tilsvarende betinget formatering.

Maker cellerne i området Ny_liste.

Vælg Hjem à Betinget formatering à Ny regel for at se dialogboksen Ny formateringsregel.

I dialogboksen Ny formateringsregel klikkes på regeltypen, der hedder Brug en formel til at bestemme, hvilke celler der skal formateres.

Indtast følgende formel i dialogboksen (se figuren):

=TÆL.HVIS(Gammel_liste;A2)=0

Når du bruger denne teknik med dine egne data, erstatter du det aktuelle område (eller navn) med dit eget område.

Klik på knappen Formater og specificer formateringen, der skal tilføjes når betingelsen er sand (en anden fyldfarve).

Klik OK.

Figuren viser resultatet. Navne der er i den gamle liste men ikke i den nye fremhæves. Og tilsvarende navne i den nye liste, der ikke er i den gamle liste fremhæves med en anden farve. Navne der findes i begge lister fremhæves ikke.

Begge disse betinget formateringer benytter funktionen TÆL.HVIS. Denne funktion tæller antallet af gange en bestemt værdi optræder i et område. Hvis formlen returnere 0, betyder det at elementet ikke optræder i området. Derfor vil den betinget formatering træde i kraft og cellens baggrundsfarve ændres.

2 Comments

  1. Kaere Bo,
    Saa vidt jeg kan se opnaaes samme resultat ved at anvende duplicate values i conditional formating, det er hurtigere og uden formel. Jeg sender et meget lille ark.
    Mvh yasmin

    • Hej Yasmin,
      Tak for din mail. Du har ret i at reglen, der ligger under Betinget formatering gør nogenlunde det samme. Men en blanding af forkærligheden for formler og det at løsningen med formlen er lidt mere fleksibel gør at jeg har valgt at introducere den!
      I modellen med formlen er der mulighed for at finde forekomster, der for eksempel optræder 3, 4 og 5 gange og ikke kun dubletter. Hvis du i formlen erstatter 1 med 2,3, 4 osv. Eller > med = kan du variere formlen og resultatet om ikke uendeligt, men alligevel!
      De bedste hilsner
      Bo

Skriv et svar

Din e-mailadresse vil ikke blive publiceret. Krævede felter er markeret med *

three + 15 =