Slå en eksakt værdi op

Slå en eksakt værdi op

Funktionerne LOPSLAG og VOPSLAG er brugbare, når du skal returnere en værdi fra en tabel (i et område) ved at se på en anden værdi.

Det klassiske eksempel på en opslagsfunktion involverer et skema med skatteprocenter (se figuren). Skatteprocenten i skemaet viser indkomstskatten for forskellige indkomstniveauer. Den følgende formel (i celle B3) returnere skatteprocenten for indkomsten i celle B2:

=LOPSLAG(B2;D2:F7;3)

Eksemplet med skattetabellen viser at LOPSLAG og VOPSLAG ikke behøver et eksakt match mellem værdien der skal slås op, og værdien der findes i opslagstabellen. Der vil dog i nogle tilfælde være brug for et eksakt match. Hvis du f.eks. slå et medarbejdernummer op, vil tæt på ikke tælle. Du har brug for et præcist match til nummeret.

For at slå præcise værdier op kan du bruge funktionerne LOPSLAG og VOPSLAG med et fjerde argument, der er sat til FALSK.

Figuren viser et regneark med en opslagstabel, der indeholder medarbejdernummerer (kolonne D) og medarbejdernavne (kolonne E). Formlen i B2, som følger, slår medarbejdernummeret i celle B1 op og returnere det tilhørende medarbejdernavn:

=LOPSLAG(B1;D2:E10;2;FALSK)

Da det sidste argument i funktionen LOPSLAG er FALSK, vil funktionen kun returnere en værdi, hvis der findes et eksakt match. Hvis der ikke findes en værdi vil formlen returnere #N/A. Det er selvfølgelig præcist det vi ønsker der skal ske. Det giver ingen mening, hvis der returneres en tilnærmelsesvis værdi for et medarbejdernummer. Bemærk også at medarbejdernummeret i kolonne D ikke er i sorteret. Hvis det sidste argumentet i LOPSLAG er FALSK, behøver værdierne ikke være sorteret i stigende orden.

Hvis du foretrækker at se noget andet end #N/A når medarbejdernummeret ikke findes, kan du bruge funktionen HVIS.FEJL til at teste for #N/A resultater, og erstatte det med en streng. Den følgende formel viser teksten ”Ikke fundet” i stedet for #N/A.

=HVIS.FEJL(LOPSLAG(B1;D2:E10;2;FALSK);"Ikke fundet")

Skriv et svar

Din e-mailadresse vil ikke blive publiceret. Krævede felter er markeret med *

eight − three =