Excel funktionen HSTAK

Resumé

Excel funktionen HSTAK kombinerer arrays vandret til et enkelt array. Hvert efterfølgende array er tilføjet til højre for det forrige array.

Formål

Kombiner områder eller arrays vandret.

Returværdi

Et enkelt kombineret område eller array.

Syntaks

=HSTAK (matrix1, [matrix2], ...)

Argumenter

array1 – Det første array eller interval, der skal kombineres.

array2 – [valgfrit] Det andet array eller interval, der skal kombineres.

Noter

Funktionen HSTAK kombinerer arrays vandret til et enkelt array. Hvert efterfølgende array er tilføjet til venstre for det forrige array. Resultatet fra HSTAK er et enkelt array, der overføres til regnearket i flere celler.

HSTAK fungerer lige så godt for områder i et regneark eller arrays i hukommelsen skabt af en formel. Outputtet fra HSTAK er fuldt dynamisk. Hvis data i et givet array ændres, opdateres resultatet fra HSTAK med det samme.

Brug HSTAK til at kombinere områder vandret og VSTAK til at kombinere områder lodret.

Grundlæggende brug

HSTAK stabler områder eller arrays vandret. I eksemplet nedenfor er området A2:C2 kombineret med området A5:B5. Hvert efterfølgende område/array er tilføjet til højre for det forrige område/array. Formlen i E2 er:

=HSTAK(A2:C2;A5:B5) 

Områder kan omfatte flere rækker, som vist nedenfor. Formlen i E2 er:

=HSTAK(A2:A4;C2:C4)

Områder med arrays

HSTAK kan arbejde i flæng med både arrays og områder. I regnearket nedenfor kombinerer vi matrixkonstanten {“A”;”B”;”C”} med området B2:B4. Formlen i C1 er:

=HSTAK({"A";"B";"C"};A1:A3)

Arrays af forskellig størrelse

Når HSTAK bruges med arrays af forskellig størrelse, vil den mindre array blive udvidet, så den matcher størrelsen af det større array. Med andre ord er det mindre array “polstres” for at matche størrelsen af det større array, som det ses i eksemplet nedenfor. Formlen i celle E2 er:

=HSTAK(A2:A6;C2:C3)

Som standard vil de celler, der bruges til udfyldning, vise fejlen #I/T. En mulighed for at fange disse fejl er at bruge funktionen HVIS.FEJL. Formlen i H2 er:

=HVIS.FEJL(HSTAK(A2:A6;C2:C3);"")

I denne formel er HVIS.FEJL konfigureret til at erstatte fejl med en tom streng (“”), der vises som en tom celle.

Skriv et svar

Din e-mailadresse vil ikke blive publiceret. Krævede felter er markeret med *

2 × one =