Udfør et tovejs opslag med INDEKS og SAMMENLIGN

Figuren viser et regneark med en tabel, der viser produktsalg per måned. For udtrække salg for en bestemt måned, skal brugeren indtaste en måned i celle B1 og produktnavn i celle B2.

Udfør et tovejs opslag med INDEKS og SAMMENLIGN
Denne tabel demonstrerer et tovejs opslag.

For at gøre tingene nemmere, bruger regnearket følgende navneområder:

Navn Referere til
Måned B1
Produkt B2
Tabel D1:H14
MånedListe D1:D14
ProduktListe D1:H1

Den følgende formel (i celle B4) bruger funktionen SAMMENLIGN til at returnere positionen for måneden i området MånedListe. Hvis for eksempel måneden er Januar returnere formlen 2, da Januar er det andet element i området MånedListe (Det første element er en blank celle D1).

=SAMMENLIGN(Måned;MånedListe;0)

Formlen i celle B5 fungerer på samme måde, men bruger området ProduktListe:

=SAMMENLIGN(Produkt;ProduktListe;0)

Den sidste formel i celle B6 returnerer det tilhørende salgstal. Den bruger funktionen INDEKS med resultaterne fra cellerne B4 og B5.

=INDEKS(Tabel;B4;B5)

Du kan kombinere disse formler til en enkelt formel, som vist her:

=INDEKS(Tabel;SAMMENLIGN(Måned;MånedListe;0);SAMMENLIGN(Produkt;ProduktListe;0))

Bo Jönsson

Skriv et svar

Din e-mailadresse vil ikke blive publiceret. Krævede felter er markeret med *

12 + six =