Find et gennemsnit med Excel

Figuren viser et dataområde der indeholder elever og deres score ved en prøve. Målet er at beregne gennemsnits scoren for alle elever samt gennemsnits score efter køn.

Indsæt subtotaler

Den første løsning involvere automatiske subtotaler. For at benytte denne metode skal dine data være sorteret efter den kolonne, der skal indeholde subtotalen. I dette tilfælde skal du sortere efter kolonnen Køn. Følg disse trin:

  1. Vælg en celle i kolonne C.
  2. Højre klik og vælg Sortér → Sortér fra A til Å i genvejsmenuen.
  3. Vælg Data → Systematisering → Subtotaler.
    Dialogboksen Subtotaler vises.
  4. I feltet Ved ændring af vælges Køn, i feltet Anvend funktionen vælges Gennemsnit og i boksen Føj subtotal til vælges Score.

Resultatet af at tilføje subtotaler vises i figuren nedenfor. Bemærk at Subtotal opstiller listen, så du kan vise og skjule detaljerækker for hver subtotal.

Formlerne der indsættes af Excel bruger funktionen SUBTOTAL med 1 som første argument (1 repræsenterer gennemsnit). Her er formlerne:

=SUBTOTAL(1;B2:B13)

=SUBTOTAL(1;B15:B26)

=SUBTOTAL(1;B2:B26)

Formelen i B28 beregner det samlede gennemsnit og bruger et område der inkluderer de to andre SUBTOTAL formler i celle B14 og B27. Funktionen ignorerer celler er indeholder andre formler med SUBTOTAL.

Se også: Find dit center med Excel

Brug formler

En anden måde at oprette gennemsnit på er ved at bruge formler. Formlen til beregning af elevernes gennemsnit er simpel:

=MIDDEL(B2:B25)

For at beregne gennemsnittet efter køn, kan du bruge funktionen MIDDEL.HVIS og oprette disse formler:

=MIDDEL.HVIS(C2:C25;"Mand";B2:B25)

=MIDDEL.HVIS(C2:C25;"Kvinde";B2:B25)

Brug Excels Pivottabel

En tredje metode til beregning af gennemsnittet er at oprette en pivottabel. Mange Excel brugere undgår at bruge pivottabeller da de betragter dem som værende for kompliceret. Som du kan se er det ret enkelt at bruge:

  1. Vælg en celle i dataområdet og vælg Indsæt à Tabeller à Pivottabel.
    Dialogboksen Pivottabel vises.
  2. Godkend at Excel har valgt det rigtige dataområde og specificer en placering i det eksisterende rengeark som placering.
    Celle E1 er et godt valg.
  3. Klik OK.
    Excel viser opgavepanelet Pivottabelfelter.
  4. Træk feltet Køn ned til sektionen RÆKKER.
  5. Træk feltet Score ned til sektionen VÆRDIER.
    Excel opretter pivottabellen men beregner summen af scoren og ikke gennemsnittet.
  6. For at ændre opsummeringsfunktionen der er benyttes, højre klikkes på en af værdierne i pivottabellen og vælg Opsummér værdier efter à Gennemsnit i genvejsmenuen.

Figuren nedenfor viser en pivottabel og panelet Pivottabelfelter.

Skriv et svar

Din e-mailadresse vil ikke blive publiceret. Krævede felter er markeret med *

twelve + thirteen =