Fraktil og Procentplads funktioner i Excel

Hvis nogle skulle sige til dig: “Din løn er i den 70. fraktil.” Gør det dig begejstret, trist eller ligeglad?

Hvis du fremsatte denne udtalelse til en gennemsnitlig person, ville de overhovedet forstå, hvad du mente?

Hvordan ville du besvare spørgsmålet “Hvad er forskellen mellem en fraktil og en procentdel?”

Lad os besvare dette spørgsmål og undervejs demonstrere, hvordan man laver meningsfulde Fraktil formler i Excel.

Lad os begynde med en definition

Forestil dig, at du lige har modtaget dine testresultater for en Excel eksamen, og får at vide, at du har svaret rigtigt på 80 % af spørgsmålene. Din karakter rangerer også i den 70. fraktil.

Hvad betyder det? Er dette godt eller dårligt?

At have en karakter den i 70. fraktil betyder, at 70 % af alle testresultater var under din testkarakter, og 30 % af alle testresultater var over din testkarakter.

Sagt på en anden måde, besvarede 70 % af testpersonerne mindre end 80 % af spørgsmålene korrekt, mens 30 % af testdeltagerne besvarede mere end 80 % af spørgsmålene rigtigt.

Når vi beskriver Fraktil, bruger vi ofte ordet procent. Det er her, forvirringen kommer ind, fordi ordet “procent” kan betyde forskellige ting afhængigt af sætningskonteksten.

Forskellen mellem procent og Fraktil

Procent

  • Procent er den matematiske værdi præsenteret ud af i alt 100.
  • Dette bruges som et middel til at sammenligne, men baseret på et enkelt tilfælde (f.eks. ét tal).
  • Procentdele angives ved hjælp af procentsymbolet (%).

Fraktil

  • Fraktil bruges til at vise en del eller rangering ved at sammenligne et tilfælde med flere tilfælde.
  • Dette repræsenterer en procentdel af værdier fundet under de specifikke værdier.
  • Fraktiler er angivet ved hjælp af et forskrevet suffiks, såsom 1., 2., 3., 4., … 99.

Overvej dette eksempel:

  • 10 personer tager en test
  • 1 af disse testpersoner besvarede 80 % af spørgsmålene rigtigt
  • De øvrige 9 testpersoner besvarede mere end 90 % af spørgsmålene rigtigt

Den ene testdeltager kan have scoret 80 % i testen, men rangeret i den nederste 10. Fraktil blandt de andre testdeltagere.

Excels Fraktil funktioner

Excel har to metoder til at bestemme fraktiler:

  • FRAKTIL
  • PROCENTPLADS

Begge funktioner er opdelt i to variationer:

  • Medtag
  • Udelad

Medtag vs. Udelad

Uden at komme ind på det matematiske ved lineær interpolation er det generiske svar på denne forskel:

  • Medtag evaluerer alle værdier i dataene fra den mindste værdi til den største værdi.
  • Udelad evaluerer alle værdier i dataene mellem den mindste værdi og den største værdi. Den mindste værdi beregnes som 1/n og den største værdi beregnes som 1-1/n hvor n er antallet af angivet elementer.

Hvis du havde en ubrudt liste over heltal fra 0 til 100, ville medtag bruge hvert tal på listen til beregningen.

Ved at bruge den samme ubrudte liste over heltal fra 0 til 100, ville Udelad beregne den mindste værdi som 0,01 og den største værdi som 0,99 med alle resterende tal faldende mellem 0,01 og 0,99.

Oprettelse af fraktilformler i Excel

Lad os se på nogle eksempeldata og se, hvordan vi kan bruge de forskellige Fraktilfunktioner.

Vi begynder med et sæt data, der viser gennemsnitslønnen i forskellige firmaer.

Vores mål er at bestemme den 25. fraktil på tværs af lønintervallet.

For at gøre dette inklusive, kan vi bruge Excels funktionen FRAKTIL.MEDTAG.

FRAKTIL.MEDTAG har følgende syntaks:

=FRAKTIL.MEDTAG(Matrix;K)

Matrix er listen over værdier, der skal beregnes.

K er den fraktilværdi, du skal bestemme.

For vores eksempel ville bestemmelse af den 25. fraktil kræve følgende formel.

=FRAKTIL.MEDTAG(B2:B21;0,25)

Det betyder, at 25% af de anførte lønninger er under 320.062 og 75% af de anførte lønninger er over 320.062.

Hvis vi ønskede at beregne den 50. og 75. fraktilværdi for disse tal, kan vi skrive følgende formler.

=FRAKTIL.MEDTAG(B2:B21;0,5)
=FRAKTIL.MEDTAG(B2:B21;0,75)

Bestemmelse af procentrangeringen

Den modsatte tilgang til disse beregninger er at tage en værdi (som f.eks. en løn) og bestemme, hvor den rangerer som en procentdel inden for en række andre værdier.

Dette kan opnås ved hjælp af funktionerne PROCENTPLADS.

Vi starter med MEDTAG version af PROCENTPLADS.

PROCENTPLADS.MEDTAG har følgende syntaks:

=PROCENTPLADS.MEDTAG(Matrix;X)

Matrix er listen over værdier, der skal beregnes.

X er den værdi, du skal bruge for at bestemme rangeringen.

I vores eksempel skal du bestemme procentrangeringen for en løn på 350.000.

=PROCENTPLADS.MEDTAG(B2:B21;350000)

Få smarte svar

Hvis du ønsker at det skal være smartere, kan du skrive følgende formler for at tage PROCENTPLADS.MEDTAG resultaterne og sammenkæde dem til tekst med en tilpasset talformatering.

(BEMÆRK: resultatet for PROCENTPLADS.MEDTAG er i celle E5.)

=TEKST(E5;”0%”)&” af lønningerne er under din løn”

=TEKST(1-E5;”0%”)&” af lønningerne er over din løn”

Husk på, at ovenstående formler kunne bruge cellereferencer for værdierne (K) eller procenterne (X) i stedet for hårdkodede værdierne.

Brug af de eksklusive versioner af disse funktioner

Udelad versionerne af disse funktioner (FRAKTIL.UDELAD og PROCENTPLADS.UDELAD) inkluderer ikke de ekstreme lave og høje ende af dataområdet.

Hvis vi ønskede at bestemme den 25. udelad fraktil af de samme lønninger, kunne vi skrive følgende formel.

=FRAKTIL.UDELAD(B2:B21;0,25)

Bemærk, at den 50. fraktil giver det samme resultat. Dog er den 25. og 75. fraktil henholdsvis lavere og højere.

Dette kompenserer for fraværet af den lave og høje ende af dataene.

Det er, som om de resterende data blev “strakt” for at nå de oprindelige lav- og højdepunkter.

Hvis vi skulle bruge udelad versionen af FRAKTIL og beregne for 0 og 1, ville vi se følgende fejl.

Hvilken en skal jeg bruge?

Brugen af MEDTAG versus UDELAD versionerne af FRAKTIL og PROCENTPLADS afhænger af din profession, størrelsen af datasættet og den type analyse, du udfører; historien, du forsøger at skabe.

Den mere almindeligt anvendte version er den medtag version.

Skriv et svar

Din e-mailadresse vil ikke blive publiceret.

eleven + 16 =